Don't recall ever seeing an answer to this one. I kept it on file, waiting
for a moment when I could put together a lab and try a couple of things.

The short answer is to configure the two middle routers as frame relay
switches, and do frame-relay routes as one normally would.

I connected my two middle routers as frame relay switches and with an NNI
interface connecting the two. As has been discussed elsewhere, the router
interface with the DCE end of the cable must still be configured with a
clock rate.

But I have been able to successfully route IPX between the two end routers
over the frame relay cloud ( the two middle routers ) Why IPX, you might
ask? Because my old friend, the 12.x IOS that refuses to route IP even
though it will route IPX phenomenon has reappeared, making me crazy once
again.

Configurations follow, for those who might want to study what I have done.

Setup:

RouterA-------------FRSwitch-------FRSwitch-----------------RouterB
IP/IPX   DTE/DCE                NNI                DTE/DCE     IP/IPX
192.168.1.1 192.168.3.1

Router A
-----------
sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
ip subnet-zero
!
ipx routing 0010.7b7e.ebd7
cns event-service server
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet0
 ip address 192.168.2.1 255.255.255.0
 ipx network AAAA
!
interface Serial0
 ip unnumbered Ethernet0
 encapsulation frame-relay
 ipx network ABAB
 no fair-queue
 clockrate 1000000
 frame-relay interface-dlci 100
 frame-relay lmi-type cisco
!
interface Serial1
 ip unnumbered Ethernet0
 encapsulation ppp
 shutdown
 clockrate 1000000
!
router eigrp 1000
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end


Router_A#sh ipx route

3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C       AAAA (NOVELL-ETHER),  Et0
C       ABAB (FRAME-RELAY),   Se0
R       BBBB [07/01] via     ABAB.0010.7b7e.ebe1,   40s, Se0

Router_A#sh ip route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Loopback0
C    192.168.2.0/24 is directly connected, Ethernet0

NO IP ROUTING!!!!!!!!!
-------------------------------------------------------------

Router B
----------
Router_B#sh run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_B
!
ip subnet-zero
!
ipx routing 0010.7b7e.ebe1
cns event-service server
!
interface Loopback0
 ip address 192.168.3.1 255.255.255.0
!
interface Ethernet0
 ip address 192.168.4.1 255.255.255.0
 ipx network BBBB
!
interface Serial0
 ip unnumbered Ethernet0
 encapsulation frame-relay
 ipx network ABAB
 clockrate 1000000
 frame-relay interface-dlci 300
 frame-relay lmi-type cisco
!
interface Serial1
 ip unnumbered Ethernet0
 encapsulation ppp
 shutdown
!
router eigrp 1000
 network 192.168.3.0
 network 192.168.4.0
!
ip classless
no ip http server
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Router_B#sh ipx route

3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C       ABAB (FRAME-RELAY),   Se0
C       BBBB (NOVELL-ETHER),  Et0
R       AAAA [07/01] via     ABAB.0010.7b7e.ebd7,    5s, Se0

Router_B#sh ip route

Gateway of last resort is not set

C    192.168.4.0/24 is directly connected, Ethernet0
C    192.168.3.0/24 is directly connected, Loopback0

NO IP ROUTING!!!

Relevant portions of the frame relay switch configs:
-----------------------------------------------------------

FRSwitch-1

interface Serial0     THIS IS THE SWITCH TO SWITCH INTERFACE
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
 frame-relay intf-type nni
 frame-relay route 200 interface Serial1 100
!
interface Serial1
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 100 interface Serial0 200

FRSwitch-2

interface Serial1/0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
 frame-relay intf-type dce     NOTICE - FR INT DCE BUT NO CLOCKRATE - DTE
CABLE IN THIS PORT
 frame-relay route 300 interface Serial1/1 200
!
interface Serial1/1  THIS IS THE SWITCH TO SWITCH INTERFACE
 no ip address
 encapsulation frame-relay
 clockrate 1007616  THIS PORT HAS A DCE CABLE IN IT
 frame-relay intf-type nni
 frame-relay route 200 interface Serial1/0 300


Hope this answers the question. My guess as to the original problem - frame
relay not set up properly, most likely in the middle.

Anyone know why my IP won't route? I still think it's a bug in the 12.x code

Chuck



-----Original Message-----
From:   [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] On Behalf Of K
Sacca
Sent:   Friday, June 16, 2000 4:24 PM
To:     [EMAIL PROTECTED]
Subject:        Frame/Relay with 2 Switches in the middle

If you have the following Frame Relay setup in a
lab, how would you configure the routers due to the
multiple switches.

+------+S3      +------+S1/2    +------+S1/0
| 4000 |        | 3640 |        |3640-1|
|      |--------| F/R  |--------| F/R  |------+
|      |        |Swtchng        |Swtchng      |
|------+    S1/3+------+    S1/1+------+      |
                                              |
                                        S0/0  |
                                +------+------+
                                | 2600 |
                                |      |
                                +------+

I tackled this as simple frame relay switching
between the 4000 S3 Int, and the 3640-1 S1/1 Int.
Everything works, and I can ping back and forth.
However, I can't seem to figure out how to extend
the frame-relay DLCI configs so that I can now
get to the 2600 S0/0 Int.

I actually tried the reverse, and setup frame-relay
switching between the 2600 S0/0 Int, and the 3640
S1/2 Int and everything works.  However, same problem,
I can't go any further to the S3 Int on the 4000.

Would you use the CONNECT command on one of the
frame-relay switches?  Or would I simply have each
F/R switch router setup with FR Route statements
acting like a chain through the 2 switches.

Thanks Much
Kamoto

__________________________________________________
Do You Yahoo!?
Send instant messages with Yahoo! Messenger.
http://im.yahoo.com/

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to