This isn't a tough one!  Sorry for the long e-mail, but check out the
attached config.  It has been sanitized.

Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname ROUTER
!
enable secret 
!
ip subnet-zero
no ip finger
!
!
!
interface Ethernet0
 ip address 2.11.215.1 255.255.255.192 secondary
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
!
interface Serial0
 bandwidth 384
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
!
interface Serial0.16 point-to-point
 description
 ip address 192.168.26.2 255.255.255.0
 no ip directed-broadcast
 ip nat outside
 frame-relay interface-dlci 16
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip nat pool ROUTER 2.11.215.2 2.11.215.2 netmask 255.255.255.192
ip nat inside source list 1 pool ROUTER overload
ip nat inside source static 192.168.20.12 2.11.215.6
ip nat inside source static 192.168.20.2 2.11.215.3
ip nat inside source static 192.168.20.3 2.11.215.4
ip nat inside source static 192.168.20.4 2.11.215.5
ip nat inside source static 192.168.20.22 2.11.215.7
ip nat inside source static 192.168.20.166 2.11.215.8
ip nat inside source static 192.168.20.206 2.11.215.9
ip nat inside source static 192.168.20.121 2.11.215.10
ip nat inside source static 192.168.20.150 2.11.215.11
ip nat inside source static 192.168.20.151 2.11.215.12
ip nat inside source static 192.168.20.154 2.11.215.13
ip nat inside source static 192.168.20.155 2.11.215.14
ip nat inside source static 192.168.20.157 2.11.215.15
ip nat inside source static 192.168.20.158 2.11.215.16
ip nat inside source static 192.168.20.159 2.11.215.17
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0.16
!
access-list 1 deny   192.168.26.2
access-list 1 deny   192.168.20.10
access-list 1 deny   192.168.20.1
access-list 1 permit any
!
line con 0
 login
 transport input none
line 1 8
line aux 0
line vty 0 4
 login
!
end
 

-----Original Message-----
From: CiscoDiety [mailto:[EMAIL PROTECTED]]
Sent: Friday, September 01, 2000 10:14 AM
To: andrew lennon; 'Erick B.'; 'Groupstudy Cisco'
Subject: Re: NAT WITHIN An ETHERNET INTERFACE.


Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.

So, unless you have it in a switched environment, you're out of luck.


================================
Clayton Dukes
Internetwork Solutions Engineer
Internetwork Management Engineer
Thrupoint, Inc.
CCNA, CCDA, CCDP, CCNP
SunCSA, Etc.
================================



----- Original Message -----
From: "andrew lennon" <[EMAIL PROTECTED]>
To: "'Erick B.'" <[EMAIL PROTECTED]>; "'Groupstudy Cisco'"
<[EMAIL PROTECTED]>
Sent: Friday, September 01, 2000 9:01 AM
Subject: RE: NAT WITHIN An ETHERNET INTERFACE.


> have you tried subinterfaces ?
>
> Andy Lennon
> CCNP/DP MCSE
>
> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
> Erick B.
> Sent: 01 September 2000 06:29
> To: [EMAIL PROTECTED]; Groupstudy Cisco
> Subject: Re: NAT WITHIN An ETHERNET INTERFACE.
>
>
>
> Each cisco interface can only be inside or outside,
> not both. Looks like you'll have to get a 2nd ethernet
> for your 2600.
>
> --- [EMAIL PROTECTED] wrote:
> > Hi,
> > I have an Ethernet Network with 2 ips.
> > One ip is Internet IP. The other is PRIVATE ip.
> > I want the machines with the private ip\'s also to
> > browse without the use of a proxy server.
> > is it possible to implement this is
> > cisco NAT or anyother service.
> >
> > The cisco IOS version is 11.3 and the router is
> > cisco 2600
> > model with a single ethernet port.
> >
> >
> > regards
> >
> >
> >
> >
> >
> -----------------------------------------------------
> > This mail sent through  http://www.sify.com
> >
> > ___________________________________
> > UPDATED Posting Guidelines:
> > http://www.groupstudy.com/list/guide.html
> > FAQ, list archives, and subscription info:
> > http://www.groupstudy.com
> > Report misconduct and Nondisclosure violations to
> [EMAIL PROTECTED]
>
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Mail - Free email you can access from anywhere!
> http://mail.yahoo.com/
>
> ___________________________________
> UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
> FAQ, list archives, and subscription info: http://www.groupstudy.com
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>
> ___________________________________
> UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
> FAQ, list archives, and subscription info: http://www.groupstudy.com
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to