If you have decided to do it with these commands, do not forget the other
UDP broadcasts which are automatically forwarded.
Have you also considered putting permanent static routes in the workstation
and server ?. Will the application allow this for communication ? If it does
, you do not have to touch the router.
Let us know how it turns out.

example:
ip helper address 10.2.2.2
no ip forward-protocol udp 69 !(this does not allow tftp broadcasts)

Winston.

-----Original Message-----
From: John Neiberger [mailto:[EMAIL PROTECTED]]
Sent: Sunday, December 31, 2000 5:34 AM
To: Trentj; [EMAIL PROTECTED]
Subject: Re: NetBios forwarding (Addendum)


You're right, I do need that in my config.  I had it in the first post, but
forgot to add it to the second one.  These two lines should be in the second
version:

int s0
ip helper-address 10.2.2.2

int s1
ip helper-address 10.1.1.1

I think this would accomplish what I'm trying, but I'm wondering what any
downsides might be and if there is a better way.

>  I've never used the "ip directed-broadcast" config to do what your trying
to
>  do. You may need to use the "ip helper-address" config to forward your
>  netbios traffic. Check out the attached URL. Hope this helps.
>  
> 
http://www.cisco.com/univercd/cc/td/doc/product/software/ssr83/rpc_r/48383.h
>  tm#xtocid670622
>  
>  
>  "John Neiberger" <[EMAIL PROTECTED]> wrote in message
>  [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
>  > Okay, after a tad more research, I've come up with the following
config,
>  > which corrects some mistakes and misunderstandings in my previous
config.
>  >
>  > interface Serial0
>  >  ip address 10.1.1.254 255.255.255.0
>  >  ip directed-broadcast 101
>  > !
>  > interface Serial1
>  >  ip address 10.2.2.254 255.255.255.0
>  >  ip directed-broadcast 102
>  > !
>  > access-list 101 permit udp host 10.1.1.1 any eq netbios-ns
>  > access-list 101 permit udp host 10.1.1.1 any eq netbios-dgm
>  > access-list 102 permit udp host 10.2.2.2 any eq netbios-ns
>  > access-list 102 permit udp host 10.2.2.2 any eq netbios-dgm
>  >
>  > Now, from what I can tell, this will do what I'm attempting, but I'd
still
>  > love to have your opinions because I have *zero* experience with
netbios
>  or
>  > broadcast forwarding.  I'd hate to break one thing while trying to fix
>  > another.  (gee, I've never done that before!)
>  >
>  > Thanks again,
>  > John
>  >
>  > >  We have some new software running on a single workstation that is
>  trying
>  > to
>  > >  use netbios to communicate with a server on a different subnet.  We
do
>  > not
>  > >  currently allow this type of forwarding, and I've never configured
it
>  > >  before.  We'd like to limit netbios forwarding to just these two
>  > machines.
>  > >  Here is my idea, let me know if this would be the way to do it.
>  > >
>  > >  access-list 1 permit 10.1.1.1  (workstation)
>  > >  access-list 2 permit 10.2.2.2  (server)
>  > >
>  > >  ip forward-protocol udp 137
>  > >  ip forward-protocol udp 138
>  > >  ip forward-protocol udp 139
>  > >
>  > >  int fastethernet1/0
>  > >  ip add 10.1.1.254 255.255.255.0
>  > >  ip directed-broadcast 1
>  > >  ip helper-address 10.2.2.2
>  > >
>  > >  int fastethernet2/0
>  > >  ip add 10.2.2.254 255.255.255.0
>  > >  ip directed-broadcast 2
>  > >  ip helper-address 10.1.1.1
>  > >
>  > >  Would this do what I'm trying to accomplish?  If not, please let me
>  know,
>  > or
>  > >  if anyone has any tips for this sort of thing, I'd love to hear
them.
>  > >
>  > >  Thanks a million, as usual!
>  > >
>  > >  John
>  > >
>  > >
>  > >
>  > >
>  > >
>  > >  _______________________________________________________
>  > >  Send a cool gift with your E-Card
>  > >  http://www.bluemountain.com/giftcenter/
>  > >
>  > >
>  > >  _________________________________
>  > >  FAQ, list archives, and subscription info:
>  > http://www.groupstudy.com/list/cisco.html
>  > >  Report misconduct and Nondisclosure violations to
[EMAIL PROTECTED]
>  >
>  >
>  >
>  >
>  >
>  > _______________________________________________________
>  > Send a cool gift with your E-Card
>  > http://www.bluemountain.com/giftcenter/
>  >
>  >
>  > _________________________________
>  > FAQ, list archives, and subscription info:
>  http://www.groupstudy.com/list/cisco.html
>  > Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>  >
>  
>  
>  _________________________________
>  FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
>  Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]





_______________________________________________________
Send a cool gift with your E-Card
http://www.bluemountain.com/giftcenter/


_________________________________
FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to