Dear Group,

A while ago I brought a problem to the group re: two networks on the same
wire, (prime and secondary on the router e0 interface) and using policy
routing so that one went out one serial and the other went out the second
serial.

Neither LAN should go out the other's serial (or come in).  Also the routes
should be advertised such that the core should not send traffic down the
wrong pipe.

All sorts of things were tried but got messed up due to the secondary
address.  Finally, using 2 ospf processes and 2 eigrp processes got the
"job" done.  A total of 4 routing processes.

However, that didn't sit right and I have being trying to do it in BGP.

I have a config that works.  It was done on a 2611 router with 6 ethernet
(instead of serial).  Here are the relevent parts.

interface Ethernet0/0
 description Uplink to LabR05
 ip address 198.103.224.2 255.255.255.252
!
interface Ethernet0/1
 description Uplink to LabR06
 ip address 198.103.224.6 255.255.255.252
!
interface Ethernet1/0
 description Client LAN
 ip address 142.226.20.1 255.255.255.0 secondary
 ip address 142.226.10.1 255.255.255.0
 ip policy route-map client
!
router bgp 65300
 network 142.226.10.0 mask 255.255.255.0
 network 142.226.20.0 mask 255.255.255.0
 neighbor 198.103.224.1 remote-as 65500
 neighbor 198.103.224.1 timers 5 10
 neighbor 198.103.224.1 route-map R5out out
 neighbor 198.103.224.5 remote-as 65500
 neighbor 198.103.224.5 timers 5 10
 neighbor 198.103.224.5 route-map R6out out
!
ip local policy route-map client
ip classless
ip route 0.0.0.0 0.0.0.0 198.103.224.1
ip route 0.0.0.0 0.0.0.0 198.103.224.5
no ip http server
!
!
ip access-list extended client1
 permit ip 142.226.10.0 0.0.0.255 any
ip access-list extended client2
 permit ip 142.226.20.0 0.0.0.255 any
route-map R5out permit 10
 match ip address client1
 set ip next-hop 198.103.224.1
!
route-map R6out permit 10
 match ip address client2
 set ip next-hop 198.103.224.5
!
route-map client permit 10
 match ip address client1
 set interface Ethernet0/0
!
route-map client permit 20
 match ip address client2
 set interface Ethernet0/1

*********************************

This works great.

HOWEVER.

Always one of these............

I have uncovered a "quirk" or bug that I can't find on CCO.  Getting ready
to open a Tac case on this one.

If the router is reloaded, after it's up and just before the "Press return
to get started!" line - I see this:

"Secondary addresses not allowed with negotiated addresses"

Processor board ID JAB024801KB (751772336)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
6 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
2 Serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
Secondary addresses not allowed with negotiated addresses


Press RETURN to get started!

********

and sure enough, the secondary address on E1/0 is gone.

I can put it back in and the router does not complain.  Save the config and
everything is happy again! (until the next reload)

Does anyone have a handle on that one??  Like what address is being
negotiated??

tia

Kevin WIgle
_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to