first question - what routes are showing up in the OSPF domain? What routes
show up in the IGRP domain?

2nd question - what is the destination address you are pinging from both A
and D ( the successful? )

offhand I would say that IGRP should be seeing a 10.0.0.0 network and a
couple of the /28's in its routing table. OSPF should be seeing all routes,
if done properly. I "think" that IGRP will not receive / import any of the
OSPF originated /28's. IGRP "should" see the classful 192.168.1.0 /24. have
you forgotten to either assign a default-metric under thee IGRP process, or
as part of your redistribute statement?

check the output of your debug ip routing command on D to see what routes
you are receiving. Also, do a trace from B to D or visa versa and see where
the path stops. betcha it's at the C-D border.

Chuck

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Hunt Lee
Sent: Thursday, December 06, 2001 11:35 PM
To: [EMAIL PROTECTED]
Subject: Redistribution Question [7:28374]


I need some help on a Redistribution question:

I have setup 4 routers:

Router A - Router B - Router C - Router D

A, B & C are running OSPF, and C & D are running IGRP - I'm trying to
redistribute between OSPF & IGRP routes:

A is connected to B with 10.1.1.100 / 24 - Serial 0

B is connected to A with 10.1.1.1 / 24 - Serial 0
B is connected to C with 192.168.1.17 /28 - Serial 1

C is connected to B with 192.168.1.18 / 28 - Serial 0
C is connected to D with 192.168.2.49 / 28 - Serial 1

D is connected to C with 192.168.2.50 / 28 - Serial 0

However, I could only ping from D to A (& vice versa), but I couldn't ping
from B to D, or D to B
N.B:  D to C (and vice versa) is fine as they are directly connected

Any help will be greatly appreciated.

Thanks in advance,

Hunt Lee


Below are the configs for the routers:

Router A
version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname RouterA

!

!

no ip domain-lookup

!

interface Ethernet0

 no ip address

 shutdown

!

interface Serial0

 no ip address

 no fair-queue

 clockrate 64000

!

interface Serial1

 ip address 10.1.1.100 255.255.255.0

 clockrate 64000

!

router ospf 100

 network 10.1.1.100 0.0.0.0 area 1

!

ip host RouterB 10.1.1.1

ip host RouterC 192.168.1.18

ip host RouterD 192.168.2.50

!

line con 0

line aux 0

 transport input all

line vty 0 4

 login

!

end


Router B
version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname RouterB

!

no ip domain-lookup

!

interface Ethernet0

 no ip address

 shutdown

!

interface Serial0

 ip address 192.168.1.17 255.255.255.240

 no fair-queue

!

interface Serial1

 ip address 10.1.1.1 255.255.255.0

!

router ospf 100

 network 192.168.1.17 0.0.0.0 area 0

 network 10.1.1.1 0.0.0.0 area 1

!

ip host RouterA 10.1.1.100

ip host RouterC 192.168.1.18

ip host RouterD 192.168.2.50

!

line con 0

line aux 0

 transport input all

line vty 0 4

 login

!

end



Router C

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RouterC

!

!

ip subnet-zero

no ip domain-lookup

ip host RouterA 10.1.1.100

ip host RouterB 192.168.1.17

ip host RouterD 192.168.2.50



!

interface Ethernet0

 no ip address

 no ip directed-broadcast

 shutdown

!

interface Serial0

 ip address 192.168.1.18 255.255.255.240

 no ip directed-broadcast

 no ip mroute-cache

 no fair-queue

 clockrate 64000

!

interface Serial1

 ip address 192.168.2.49 255.255.255.240

 no ip directed-broadcast

 clockrate 64000

!

interface BRI0

 no ip address

 no ip directed-broadcast

 shutdown

!

router ospf 100

 redistribute igrp 200 metric-type 1 subnets

 network 192.168.1.18 0.0.0.0 area 0

 default-metric 10

!

router igrp 200

 redistribute ospf 100

 network 192.168.2.0

 default-metric 10000 100 255 1 1500

!

ip classless

ip route 192.168.1.0 255.255.255.0 Null0

!

line con 0

 transport input none

line aux 0

line vty 0 4

 login

!

end



Router D

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RouterD

!!

ip subnet-zero

no ip finger

no ip domain-lookup

ip host RouterC 192.168.1.49

ip host RouterB 192.168.1.17

ip host RouterA 10.1.1.100

!

interface Ethernet0

 no ip address

 shutdown

!

interface Serial0

 ip address 192.168.2.50 255.255.255.240

 no fair-queue

!

interface Serial1

 no ip address

 shutdown

!

router igrp 200

 network 192.168.2.0

!

ip classless

ip http server

!

line con 0

 exec-timeout 0 0

 transport input none

line 1 16

line aux 0

line vty 0 4

 login

!

end




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=28379&t=28374
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to