So it fails when you have numbered on one side and unnumbered on the other
side and you are running RIP?

What did "show ip route" tell you when the problem occured? Were the
relevant routes in both routers' tables?

What address does sdmheadend use to send the echo? If it's using
172.20.110.10, then it won't work because switchrouter doesn't have a route
back to that. It only has a route back to 12.0.0.0?

With extended ping you can set the ip address that the router should use.

Also, enable debug ip icmp (on a non-operational router anyway) and see
what's really happening.

Also, see the last message from Claudio. It may have something to do with
sdmheadend not having a valid next hop address since its next hop is
unnumbered, but then we would expect when they are both unnumbered and the
loopbacks are in different subnets, there would be a problem too, and there 
isn't. Anyway, "show ip route" should tell you a lot.

Priscilla

Deepak N wrote:
> 
> Hi all 
> 
> The following are the configurations of the routers and the
> ping outputs.
> I have given 3 cases. 
> 
> 1) When ip unnumbered at one end and static routes are defined 
> 
> sdmheadend#sh run
> Building configuration...
> 
> Current configuration : 1115 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname sdmheadend
> !
> !
> !
> !
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> !
> !
> !
> voice call carrier capacity active
> !
> !
> !
> !
> !
> !
> !
> !
> !
> mta receive maximum-recipients 0
> !
> !
> !
> !
> interface FastEthernet0/0
>  ip address 172.20.110.10 255.255.255.192
>  duplex auto
>  speed auto
> !
> interface FastEthernet0/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface ATM1/0
>  no ip address
>  shutdown
>  no atm ilmi-keepalive
>  dsl operating-mode auto
>  no fair-queue
> !
> interface FastEthernet1/0
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/0
>  ip address 12.12.12.1 255.255.255.0
>  no fair-queue
>  clockrate 2000000
> !
> interface FastEthernet1/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/1
>  no ip address
>  shutdown
>  clockrate 2000000
> !
> ip classless
> ip route 200.200.200.0 255.255.255.0 Serial1/0
> ip http server
> !
> !
> !
> !
> call rsvp-sync
> !
> !
> mgcp profile default
> !
> dial-peer cor custom
> !
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> !
> end
> 
> 
> sdmheadend# ping 200.200.200.11
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 200.200.200.11, timeout is 2
> seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max =
> 1/2/4 ms
> sdmheadend#
> 
> 
> 
> 
> 
> 
> switchrouter#sh run
> Building configuration...
> 
> Current configuration : 746 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname switchrouter
> !
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> ip ssh time-out 120
> ip ssh authentication-retries 3
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback0
>  ip address 200.200.200.11 255.255.255.0
> !
> interface FastEthernet0/0
>  no ip address
>  shutdown
>  speed auto
> !
> interface Serial0/0
>  ip unnumbered Loopback0
>  no fair-queue
> !
> interface Serial0/1
>  no ip address
>  shutdown
> !
> ip classless
> ip route 12.12.12.0 255.255.255.0 Serial0/0
> no ip http server
> ip pim bidir-enable
> !
> !
> !
> call rsvp-sync
> !
> dial-peer cor custom
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> no scheduler allocate
> end
> 
> switchrouter#ping 12.12.12.1
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2
> seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max =
> 1/2/4 ms
> switchrouter#
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 2)  When routing protocol RIP is running
> 
> 
> sdmheadend#sh run
> Building configuration...
> 
> Current configuration : 1099 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname sdmheadend
> !
> !
> !
> !
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> !
> !
> !
> voice call carrier capacity active
> !
> !
> !
> !
> !
> !
> !
> !
> !
> mta receive maximum-recipients 0
> !
> !
> !
> !
> interface FastEthernet0/0
>  ip address 172.20.110.10 255.255.255.192
>  duplex auto
>  speed auto
> !
> interface FastEthernet0/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface ATM1/0
>  no ip address
>  shutdown
>  no atm ilmi-keepalive
>  dsl operating-mode auto
>  no fair-queue
> !
> interface FastEthernet1/0
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/0
>  ip address 12.12.12.1 255.255.255.0
>  no fair-queue
>  clockrate 2000000
> !
> interface FastEthernet1/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/1
>  no ip address
>  shutdown
>  clockrate 2000000
> !
> router rip
>  network 12.0.0.0
> !
> ip classless
> ip http server
> !
> !
> !
> !
> call rsvp-sync
> !
> !
> mgcp profile default
> !
> dial-peer cor custom
> !
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> !
> end
> 
> sdmheadend# ping 200.200.200.11
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 200.200.200.11, timeout is 2
> seconds:
> .....
> Success rate is 0 percent (0/5)
> sdmheadend#
> 
> 
> 
> switchrouter#sh run
> Building configuration...
> 
> Current configuration : 738 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname switchrouter
> !
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> ip ssh time-out 120
> ip ssh authentication-retries 3
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback0
>  ip address 200.200.200.11 255.255.255.0
> !
> interface FastEthernet0/0
>  no ip address
>  shutdown
>  speed auto
> !
> interface Serial0/0
>  ip unnumbered Loopback0
>  no fair-queue
> !
> interface Serial0/1
>  no ip address
>  shutdown
> !
> router rip
>  network 200.200.200.0
> !
> ip classless
> no ip http server
> ip pim bidir-enable
> !
> !
> !
> call rsvp-sync
> !
> dial-peer cor custom
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> no scheduler allocate
> end
> 
> switchrouter#ping 12.12.12.1
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2
> seconds:
> .....
> Success rate is 0 percent (0/5)
> switchrouter#
> 
> 
> 
> 3) When both sides are unnumbered and running routing protocol
> 
> 
> sdmheadend#sh run
> Building configuration...
> 
> Current configuration : 1146 bytes
> !
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname sdmheadend
> !
> !
> !
> !
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> !
> !
> !
> voice call carrier capacity active
> !
> !
> !
> !
> !
> !
> !
> !
> !
> mta receive maximum-recipients 0
> !
> !
> !
> !
> interface Loopback0
>  ip address 20.20.20.1 255.255.255.0
> !
> interface FastEthernet0/0
>  ip address 172.20.110.10 255.255.255.192
>  duplex auto
>  speed auto
> !
> interface FastEthernet0/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface ATM1/0
>  no ip address
>  shutdown
>  no atm ilmi-keepalive
>  dsl operating-mode auto
>  no fair-queue
> !
> interface FastEthernet1/0
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/0
>  ip unnumbered Loopback0
>  no fair-queue
>  clockrate 2000000
> !
> interface FastEthernet1/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial1/1
>  no ip address
>  shutdown
>  clockrate 2000000
> !
> router rip
>  network 20.0.0.0
> !
> ip classless
> ip http server
> !
> !
> !
> !
> call rsvp-sync
> !
> !
> mgcp profile default
> !
> dial-peer cor custom
> !
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> !
> end
> 
> sdmheadend# ping 200.200.200.11
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 200.200.200.11, timeout is 2
> seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max =
> 1/2/4 ms
> sdmheadend#
> 
> 
> 
> switchrouter#sh run
> Building configuration...
> 
> Current configuration : 738 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname switchrouter
> !
> !
> memory-size iomem 5
> ip subnet-zero
> !
> !
> !
> ip audit notify log
> ip audit po max-events 100
> ip ssh time-out 120
> ip ssh authentication-retries 3
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback0
>  ip address 200.200.200.11 255.255.255.0
> !
> interface FastEthernet0/0
>  no ip address
>  shutdown
>  speed auto
> !
> interface Serial0/0
>  ip unnumbered Loopback0
>  no fair-queue
> !
> interface Serial0/1
>  no ip address
>  shutdown
> !
> router rip
>  network 200.200.200.0
> !
> ip classless
> no ip http server
> ip pim bidir-enable
> !
> !
> !
> call rsvp-sync
> !
> dial-peer cor custom
> !
> !
> !
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> no scheduler allocate
> end
> 
> switchrouter#ping 20.20.20.1
> 
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 20.20.20.1, timeout is 2
> seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max =
> 1/1/4 ms
> switchrouter#
> 
> 
> Regards
> Deepak




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=62153&t=62134
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to