Ovidiu Predescu wrote:
OK, let's wrap up this discussion.

What I'll do is revert to the old naming and at the same time provide some useful aliases for the default functions.

sendPage <=> sendPageAndWait

sendPageAndContinue <=> sendPageNoWait

This means the sendPage() function will also be accessible as sendPageAndWait(), and sendPageAndContinue() will be accessible as sendPageNoWait().

Since in JavaScript functions are objects, if you don't like the default names you can just assign them a new name without any penalty in runtime performance:

var sendPageWithSomeNewIllustrativeName;

sendPageWithSomeNewIllustrativeName = sendPage;

and so on.
Oh no. Apart from stinking of FS, don't you think that this is going to confuse the hell out of whomever is going to debug your scripts in the future?

If I were a commiter, I'd express my -1 on this ;-).

I would like us to spend our energy in discussing better things that names (and, ahem, implementing and documenting them). For some reasons discussions on names seem to provide the most heated debates.
Agreed. I stopped following naming thread after the first two or three messages. And I have already switched from sendPage/sendPageAndContinue to sendPageAndWait/sendPage, so I'd like not to switch back. So my proposal (not a vote) is to keep things as they are now, i.e. sendPage and sendPageAndWait.

Ugo

--
Ugo Cei - http://www.beblogging.com/blog/


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]



Reply via email to