+1 on adding the method to IList... I have *lot* of code that look like var index:int = list.getItemIndex(object); if (index >= 0) { list.removeItemAt(index); }
I think this is ugly and verbose, and it pollutes my function namespace - I ends up with "indexOfItemToRemove1" and some like this, as AS3 lacks java-like block-level variables. Having static helper functions to mitigate this kind of micro-issues is not ideal, as it makes the code less readable and fluent, at least for my eyes. I also think it is actually correct that existing methods are broken on first compile: its a nice way for owners of that code to be aware of the change, and thus look up if their custom method implementation can be trashed or must be kept and renamed for some reason. 2013/3/25 Alex Harui <aha...@adobe.com> > > > > On 3/25/13 8:00 AM, "Carlos Rovira" <carlos.rov...@codeoscopic.com> wrote: > > > So Alex, > > > > what we do? revert? let the change live? make a Discuss thread so people > > could express the phylosophy with this issue and future similar tickets? > > > > Please, let us know so we can act accordingly > > > It is up to you. I have stated my concerns. There is no right or wrong > answer. If you are willing to take the time to start a discuss or poll, > feel free. So far, four people have voiced opinions and nobody thinks you > must revert. > > -- > Alex Harui > Flex SDK Team > Adobe Systems, Inc. > http://blogs.adobe.com/aharui > >