> On Sept. 15, 2014, 4:38 p.m., Benjamin Hindman wrote:
> > src/master/master.cpp, line 4010
> > <https://reviews.apache.org/r/25250/diff/4/?file=682254#file682254line4010>
> >
> >     I suggest we use TASK_LOST here instead. We definitely want a terminal 
> > state like TASK_KILLED, but we've reserved TASK_KILLED for when a framework 
> > has actually intiated the kill itself, and thus I'd prefer not to overload 
> > the semantics. This might be a good candidate for a new task state, e.g., 
> > TASK_REMOVED, which has been discussed in the past, but I can't recall if 
> > there is a JIRA for that or not. If not, it would be great to have you 
> > create one Alex so we can have a discussion about how to introduce new task 
> > states (and maybe even a way to introduce sub-states that framework writers 
> > themselves could customize).
> 
> Alexander Rukletsov wrote:
>     I used to have `TASK_LOST` here, but my understanding is that `TASK_LOST` 
> is used for abnormal situations, i.e. when the task is not finished not 
> because of scheduler's direct command, but because of some external reasons. 
> I agree, that a new task state is a very good solution. We have [this 
> ticket](https://issues.apache.org/jira/browse/MESOS-343), one solution for 
> which would be to introduce something like `TaskStatusExplained` or a 
> protobuf message for every task. But maybe for this situation something like 
> `TASK_ABANDONED` would be rather descriptive.

Keeping TASK_KILLED, but added comments for clarity.


- Alexander


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25250/#review53350
-----------------------------------------------------------


On Sept. 22, 2014, 4:25 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/25250/
> -----------------------------------------------------------
> 
> (Updated Sept. 22, 2014, 4:25 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Till Toenshoff.
> 
> 
> Bugs: MESOS-1736
>     https://issues.apache.org/jira/browse/MESOS-1736
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> When a framework is shut down e.g. by calling driver.stop() from the 
> scheduler, running tasks are marked KILLED before migrating them to completed.
> 
> 
> Diffs
> -----
> 
>   src/master/master.cpp e5d30e9 
>   src/tests/master_tests.cpp 8e4ec1d 
> 
> Diff: https://reviews.apache.org/r/25250/diff/
> 
> 
> Testing
> -------
> 
> make check (OS X)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>

Reply via email to