-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/51029/#review162866
-----------------------------------------------------------




core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 520)
<https://reviews.apache.org/r/51029/#comment234229>

    `testCoord_endOfMonthTillMiddleOfNext_differenceIsCalculatedCorrectly()` 
would be a better name.



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 538)
<https://reviews.apache.org/r/51029/#comment234230>

    `testCoord_middleOfMonth_tillEndOfNext_differenceIsCalculatedCorrectly()` 
would be a better name.



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 546)
<https://reviews.apache.org/r/51029/#comment234231>

    I like that :)



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 551 - 559)
<https://reviews.apache.org/r/51029/#comment234280>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 563)
<https://reviews.apache.org/r/51029/#comment234253>

    `testCoord_startIsAfterEnd_throw()` would be a better name.



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 564 - 573)
<https://reviews.apache.org/r/51029/#comment234281>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 576)
<https://reviews.apache.org/r/51029/#comment234254>

    `testCoord_latestEnd_notSupported()` would be a better name.



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 577 - 585)
<https://reviews.apache.org/r/51029/#comment234282>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(line 589)
<https://reviews.apache.org/r/51029/#comment234278>

    `testCoord_endOfWeeksTillCurrent_correct()` would be a better name.



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 624 - 632)
<https://reviews.apache.org/r/51029/#comment234283>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 637 - 646)
<https://reviews.apache.org/r/51029/#comment234279>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 650 - 658)
<https://reviews.apache.org/r/51029/#comment234284>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 715 - 723)
<https://reviews.apache.org/r/51029/#comment234285>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```



core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
(lines 737 - 746)
<https://reviews.apache.org/r/51029/#comment234286>

    For all similar `try-catch` stories like this, beginning w/ JUnit 4.7:
    
    ```
    @Rule
    public ExpectedException expected = ExpectedException.none();
    ...
    expected.expect(MyOoziException.class);
    expected.expectMessage(myExceptionMessageString);
    performAndThrow();
    ```


- András Piros


On Jan. 24, 2017, 10:49 p.m., Satish Saley wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/51029/
> -----------------------------------------------------------
> 
> (Updated Jan. 24, 2017, 10:49 p.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-2630
>     https://issues.apache.org/jira/browse/OOZIE-2630
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Oozie Coordinator EL Functions to get first day of the week/month
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/command/coord/CoordCommandUtils.java 
> 0af7edc 
>   core/src/main/java/org/apache/oozie/command/coord/CoordSubmitXCommand.java 
> 969336d 
>   core/src/main/java/org/apache/oozie/coord/CoordELFunctions.java 925a7aa 
>   core/src/main/java/org/apache/oozie/coord/TimeUnit.java 5b37639 
>   core/src/main/java/org/apache/oozie/util/DateUtils.java 3caf0a2 
>   core/src/main/resources/oozie-default.xml ad10386 
>   
> core/src/test/java/org/apache/oozie/command/coord/TestCoordCommandUtils.java 
> 7062e69 
>   
> core/src/test/java/org/apache/oozie/command/coord/TestCoordMaterializeTransitionXCommand.java
>  29e7ca1 
>   core/src/test/java/org/apache/oozie/coord/TestCoordELFunctions.java be60133 
>   core/src/test/resources/coord-dataset-endOfDays.xml PRE-CREATION 
>   core/src/test/resources/coord-dataset-endOfMonths.xml PRE-CREATION 
>   core/src/test/resources/coord-dataset-endOfWeeks.xml PRE-CREATION 
>   docs/src/site/twiki/CoordinatorFunctionalSpec.twiki e3ac514 
> 
> Diff: https://reviews.apache.org/r/51029/diff/
> 
> 
> Testing
> -------
> 
> Tested locally
> 
> 
> Thanks,
> 
> Satish Saley
> 
>

Reply via email to