-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68102/#review206592
-----------------------------------------------------------




core/src/main/java/org/apache/oozie/action/hadoop/JavaActionExecutor.java
Lines 1781-1782 (patched)
<https://reviews.apache.org/r/68102/#comment289592>

    Please remove code comment and extract to a well-named method instead.



core/src/test/java/org/apache/oozie/action/hadoop/LauncherMainTester.java
Lines 106-121 (patched)
<https://reviews.apache.org/r/68102/#comment289594>

    Extract method.



core/src/test/java/org/apache/oozie/action/hadoop/SleepMapperReducerForTest.java
Lines 32 (patched)
<https://reviews.apache.org/r/68102/#comment289596>

    `SLEEP_TIME_MILLIS_KEY` is a better name.



core/src/test/java/org/apache/oozie/action/hadoop/SleepMapperReducerForTest.java
Lines 60-61 (patched)
<https://reviews.apache.org/r/68102/#comment289597>

    Isn't emitting another message also just after sleep a good idea?



core/src/test/java/org/apache/oozie/action/oozie/TestSubWorkflowActionExecutor.java
Lines 544 (patched)
<https://reviews.apache.org/r/68102/#comment289599>

    Please remove white space between method name and brackets.



core/src/test/java/org/apache/oozie/action/oozie/TestSubWorkflowActionExecutor.java
Lines 555-574 (patched)
<https://reviews.apache.org/r/68102/#comment289600>

    Please extract to `private static class ApplicationIdExistsPredicate 
implements Predicate<Boolean>`.



core/src/test/java/org/apache/oozie/action/oozie/TestSubWorkflowActionExecutor.java
Lines 581-588 (patched)
<https://reviews.apache.org/r/68102/#comment289602>

    Please extract to `private static class SubWorkflowActionRunningPredicate 
implements Predicate<Boolean>`.



core/src/test/java/org/apache/oozie/action/oozie/TestSubWorkflowActionExecutor.java
Lines 708-712 (patched)
<https://reviews.apache.org/r/68102/#comment289601>

    Please use latest schema version `1.0`.


- András Piros


On July 30, 2018, 8:42 a.m., Kinga Marton wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68102/
> -----------------------------------------------------------
> 
> (Updated July 30, 2018, 8:42 a.m.)
> 
> 
> Review request for oozie, András Piros and Peter Cseh.
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Tags were not generated properly for external child jobs launched from subWFs 
> and they were not killed.
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/oozie/action/ActionExecutor.java 71bd36ae6 
>   core/src/main/java/org/apache/oozie/action/hadoop/JavaActionExecutor.java 
> a1a9671ab 
>   core/src/test/java/org/apache/oozie/action/hadoop/LauncherMainTester.java 
> fdca5706e 
>   
> core/src/test/java/org/apache/oozie/action/hadoop/SleepMapperReducerForTest.java
>  PRE-CREATION 
>   
> core/src/test/java/org/apache/oozie/action/oozie/TestSubWorkflowActionExecutor.java
>  e074d482f 
> 
> 
> Diff: https://reviews.apache.org/r/68102/diff/1/
> 
> 
> Testing
> -------
> 
> Tested manually.
> Added Junit test.
> 
> 
> Thanks,
> 
> Kinga Marton
> 
>

Reply via email to