[ https://issues.apache.org/jira/browse/PHOENIX-1705?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14371717#comment-14371717 ]
ramkrishna.s.vasudevan commented on PHOENIX-1705: ------------------------------------------------- Thanks to James for pointing out the case where the 'short' array gets changed to 'int'. Nice catch. {code} offsetArrayPosition+elementLength+offsetArrayLength+Bytes.SIZEOF_INT+Bytes.SIZEOF_BYTE {code} Instead of repeating the common part in these calculation ensure that you move them to a local variable and substitute that local variable where ever possible. I think that would make the code easier to read too. One question, if a null is passed ato ARRAY_APPEND ['abc','def'][null], ideally we need not do anything. Are we handling that here. > implement ARRAY_APPEND built in function > ---------------------------------------- > > Key: PHOENIX-1705 > URL: https://issues.apache.org/jira/browse/PHOENIX-1705 > Project: Phoenix > Issue Type: Sub-task > Reporter: Dumindu Buddhika > Assignee: Dumindu Buddhika > Attachments: > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function1.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function2.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function3.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function4.patch, > PHOENIX-1705_implement_ARRAY_APPEND_built_in_function5.patch > > -- This message was sent by Atlassian JIRA (v6.3.4#6332)