On 13/01/12 7:49 PM, Manu wrote:
On 13 January 2012 21:06, Peter Alexander <peter.alexander...@gmail.com
<mailto:peter.alexander...@gmail.com>> wrote:

    Also, slight bikeshedding issue: I'm not so sure on using names like
    int4 for vectors. You see things like int32 a lot to mean a 32-bit
    integer, or int8 to mean an 8-bit integer. Using this notation for
    vectors may be confusing.


I had the same feeling.
short8 really made me instanytly uncomfortable. I'm so used to seeing a
number on the end of a trivial type as being the width in bits. Even
though I knew exactly what I was looking at, I still unconsciously
assumed this was an 8bit type...

It makes perfect sense for float4, since it's completely absurd to
imagine a 4bit float, and it's also conventional from Cg and HLSL.
I wonder if there's a nice naming convention to mitigate this problem?
Perhaps vshort8? Or some other small prefix/suffix?

Honestly, I be happy with any name as long as it was unambiguous.

vshort8
short8v
short8_v
vec_short8
vec8_short
short_vec8
short_v8
...

Anything will do. Just stick a v, vec, or vector somewhere and I'll be happy.

Reply via email to