On 1/13/2012 2:36 PM, Andrei Alexandrescu wrote:
All names should have a __ prepended, and then the library defines names for
them such as vec!(int, 4) that obey module lookup and all. Dumping a wheelbarrow
of confusable new keywords doesn't sound right at all.

They're not keywords, they are (literally) simple aliases:

   alias Vector!(int[4]) int4;

As aliases, they obey all scoping and disambiguation rules, which I think is superior to using __ prefixes.

You could use Vector!(int[4]) everywhere instead, but I submit it's a bit klunky to do that and might as well provide a set of aliases (or else people will produce their own aliases and they'll all have different spellings).

Reply via email to