Excellent work, well done. I have a couple of questions/ideas though.

1. The use of bit flags irks me. Would it be possible just to use numerous 
keyword arguments to the new get_fields ?
2. Since you've reduced the API to effectively two functions (get_fields, 
get_field), is it still necessary to contain those methods on an inner 
object? Can't the new methods live directly on the model? If they can't be 
put directly on the model for some reason, I would consider a better name 
than "meta". I can't think of a reason that the name meta should be used 
other than history. If you were to think about the purpose of the API 
without the associated history, what would you call it?

log = Log.objects.get(pk=1)
log.get_fields(concrete=True, m2m=True, related=True)

log.get_field('log_level') # we're being explicit about the field name, no 
need for options


Thoughts?

I'll take a better look at the PR and see if I can offer anything with 
regards to your performance optimisations.

Josh 

-- 
You received this message because you are subscribed to the Google Groups 
"Django developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to django-developers+unsubscr...@googlegroups.com.
To post to this group, send email to django-developers@googlegroups.com.
Visit this group at http://groups.google.com/group/django-developers.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-developers/7496ef6d-4e88-41f4-b2b8-1bd2efa96aea%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to