Hi, Manikandan, On 21.02.2024 07:35, Manikandan Muralidharan wrote: > This patch series aims to add support for XLCDC IP of sam9x7 SoC family > to the DRM subsystem.XLCDC IP has additional registers and new > configuration bits compared to the existing register set of HLCDC IP. > The new compatible string "microchip,sam9x75-xlcdc" is defined for sam9x75 > variant of the sam9x7 SoC family.The is_xlcdc flag under driver data and > IP specific driver ops helps to differentiate the XLCDC and existing HLCDC > code within the same driver. > > changes in v8: > * Re-arrange the patch set to prepare and update the current HLCDC > code base with the new LCDC IP based driver ops and then add support > for XLCDC code changes. > * Fix Cosmetic issues. > > changes in v7: > * LCDC IP driver ops functions are declared static and its > declaration are removed. > > changes in v6: > * Fixed Cosmetic defects. > * Added comments for readability. > > changes in v5: > * return value of regmap_read_poll_timeout is checked in failure > case. > * HLCDC and XLCDC specific driver functions are now invoked > using its IP specific driver ops w/o the need of checking is_xlcdc flag. > * Removed empty spaces and blank lines. > > changes in v4: > * fixed kernel warnings reported by kernel test robot. > > changes in v3: > * Removed de-referencing the value of is_xlcdc flag multiple times in > a single function. > * Removed cpu_relax() call when using regmap_read_poll_timeout. > * Updated xfactor and yfactor equations using shift operators > * Defined CSC co-efficients in an array for code readability. > > changes in v2: > * Change the driver compatible name from "microchip,sam9x7-xlcdc" to > "microchip,sam9x75-xlcdc". > * Move is_xlcdc flag to driver data. > * Remove unsed Macro definitions. > * Add co-developed-bys tags > * Replace regmap_read() with regmap_read_poll_timeout() call > * Split code into two helpers for code readablitity. > --- > > Durai Manickam KR (1): > drm: atmel-hlcdc: Define XLCDC specific registers > > Manikandan Muralidharan (6): > drm: atmel-hlcdc: add driver ops to differentiate HLCDC and XLCDC IP > drm: atmel_hlcdc: Add support for XLCDC using IP specific driver ops > drm: atmel-hlcdc: add DPI mode support for XLCDC > drm: atmel-hlcdc: add vertical and horizontal scaling support for > XLCDC > drm: atmel-hlcdc: add support for DSI output formats > drm: atmel-hlcdc: add LCD controller layer definition for sam9x75 >
Only minor comments from me (check individual patches). W/ or w/o those addressed you can add: Reviewed-by: Claudiu Beznea <claudiu.bez...@tuxon.dev>