Hi Bastien, Thank you so much for the thorough discussion and your guidance -- I'm very happy with the names we landed on. “Children-only” captures the behaviour perfectly.
I was initially clinging to “recursive”, but your point about the ambiguity of “direct-children” really convinced me. The new naming is clearer, preserves the existing polarity, and avoids any migration headache. A much better outcome. To summarize what we've settled on: - Rename `org-checkbox-hierarchical-statistics' to `org-checkbox-children-only-statistics' - Rename `org-hierarchical-todo-statistics' to `org-todo-children-only-statistics' Old names will remain as obsolete aliases; polarity stays unchanged. Ihor, could you please review and let us know if you agree with this direction? Once confirmed, I’ll prepare the patch. Best, -- Slawomir Grochowski
