Slawomir Grochowski <[email protected]> writes:

> Attached is the patch implementing the agreed renames:
>
> - `org-checkbox-hierarchical-statistics' to
>   `org-checkbox-children-only-statistics'

It does not. Looks like you attached an older (?) version of the patch
that uses org-checkbox-direct-children-statistics.

> - `org-hierarchical-todo-statistics' to
>   `org-todo-children-only-statistics'

Same.

> The patch also updates all uses, the manual, ORG-NEWS, and the relevant
> tests.  The tests additionally verify that the obsolete names resolve
> to the new variables.

You also added a branch new test. Why?

> Subject: [PATCH] org: Rename statistics scope options
>
> * lisp/org-list.el (org-checkbox-direct-children-statistics):
> Rename from `org-checkbox-hierarchical-statistics'.  Update uses.
> * lisp/org.el (org-todo-direct-children-statistics): Rename from
> `org-hierarchical-todo-statistics'.
> (org-update-parent-todo-statistics): Use the new name.
> * lisp/org-compat.el (org-checkbox-hierarchical-statistics)
> (org-hierarchical-todo-statistics): Define obsolete aliases.
> * testing/lisp/test-org-list.el
> (test-org-list/update-checkbox-count): Test the obsolete alias and use
> the new checkbox option.
> * testing/lisp/test-org.el
> (test-org/update-todo-statistics-cookies): Test the obsolete alias and
> direct-children and recursive collection scopes.
> * doc/org-manual.org: Document the new option names.
> * etc/ORG-NEWS: Announce the renames.
>
> Refactoring: Rename Variable.
>
> No behavior change.

It is a good idea to link to this thread. Otherwise, the rename sounds 
arbitrary.

> +++ b/doc/org-manual.org
> @@ -4711,12 +4711,12 @@ If a heading has both checkboxes and TODO children 
> below it, the
>  meaning of the statistics cookie becomes ambiguous.  Set the property
>  =COOKIE_DATA= to either =checkbox= or =todo= to resolve this issue.
>  
> -#+vindex: org-hierarchical-todo-statistics
> +#+vindex: org-todo-direct-children-statistics

I generally prefer keeping the obsolete variable names in the index.
This way, people can still find them in the manual and see the new name.

> -(defcustom org-checkbox-hierarchical-statistics t
> +(defcustom org-checkbox-direct-children-statistics t

I think we should bump :package-version after the rename.

-- 
Ihor Radchenko // yantar92,
Org mode maintainer,
Learn more about Org mode at <https://orgmode.org/>.
Support Org development at <https://liberapay.com/org-mode>,
or support my work at <https://liberapay.com/yantar92>

Reply via email to