Hello.

On 14/02/17 16:11, Stefan Schmidt wrote:
> Hello.
>
> Taking over the ABI reports from Tom you can now find the latest report
> here:
> https://devs.enlightenment.org/~stefan/compat_reports/efl/1.18.0_to_1.19.0/compat_report.html
>
> Please have a look at it and bring up any issues you spot or fix them
> directly. :)

Here is what I spotted so far (ignoring plain eo changes but taking into 
account eo legacy APIs):

Added APIs:

Ecore_Evas.h, libecore_evas.so.1.19.0
ecore_evas_cursor_device_get ( Ecore_Evas const* ee, Efl_Input_Device* 
pointer, Evas_Object** obj, int* layer, int* hot_x, int* hot_y )
ecore_evas_object_cursor_device_set ( Ecore_Evas* ee, Efl_Input_Device* 
pointer, Evas_Object* obj, int layer, int hot_x, int hot_y )

Why has the set a _object_ in the function name and the get not?


edje_object.eo.legacy.h, libedje.so.1.19.0
edje_object_seat_get ( Edje_Object const* obj, Eina_Stringshare* name )
edje_object_seat_name_get ( Edje_Object const* obj, Efl_Input_Device* 
device )

efl_canvas_object.eo.legacy.h, libevas.so.1.19.0
evas_object_pointer_device_in_get ( Efl_Canvas_Object const* obj, 
Efl_Input_Device* pointer )
evas_object_pointer_in_get ( Efl_Canvas_Object const* obj )
evas_object_pointer_mode_by_device_get ( Efl_Canvas_Object const* obj, 
Efl_Input_Device* dev )
evas_object_pointer_mode_by_device_set ( Efl_Canvas_Object* obj, 
Efl_Input_Device* dev, enum Efl_Input_Object_Pointer_Mode pointer_mode )
evas_object_seat_focus_add ( Efl_Canvas_Object* obj, Efl_Input_Device* 
seat )
evas_object_seat_focus_check ( Efl_Canvas_Object* obj, Efl_Input_Device* 
seat )
evas_object_seat_focus_del ( Efl_Canvas_Object* obj, Efl_Input_Device* 
seat )
evas_object_seat_focus_get ( Efl_Canvas_Object const* obj )

Is the seat stuff supposed to be exposed to legacy? I can see them used 
in src/lib/edje/edje_program.c, but I wonder if they should wait for 
interfaces or should be exposed now.


emile_image.h, libemile.so.1.19.0
emile_image_register ( Emile_Image* image, Emile_Action_Cb callback, 
Emile_Action action, void const* data )

Maybe rename this to emile_image_cb_register?



Removed APIs:

elm_pan.eo.legacy.h, libelementary.so.1.18.0
elm_pan_gravity_get ( Elm_Pan const* obj, double* x, double* y )
elm_pan_gravity_set ( Elm_Pan* obj, double x, double y )

evas_out.eo.legacy.h, libevas.so.1.18.0
evas_output_engine_info_get ( Evas_Out const* obj )
evas_output_engine_info_set ( Evas_Out* obj, Evas_Engine_Info* info )
evas_output_view_get ( Evas_Out const* obj, Evas_Coord* x, Evas_Coord* 
y, Evas_Coord* w, Evas_Coord* h )
evas_output_view_set ( Evas_Out* obj, Evas_Coord x, Evas_Coord y, 
Evas_Coord w, Evas_Coord h )

These have been exposed to legacy to all users in 1.18 it seems. If 
there is no good reason why we are going top break API here we should 
quickly restore these.

regards
Stefan Schmidt

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to