Glen Mazza wrote:
Team,

...

1.) Drop the apps.Driver class and incorporate its remaining code into apps.Fop.

Reason:  "Fop" appears to be a better self-documenting
class name within user's embedded code.  It's also a
neat name for a product.  User's code would move from
looking like this:

// Construct driver
Driver driver = new Driver();
// Setup Renderer
driver.setRenderer(Driver.RENDER_PDF);
....
Result res = new SAXResult(driver.
getContentHandler());



To this:

// Construct FOP instance
Fop fop = new Fop();
// Setup Renderer
fop.setRenderer(Fop.RENDER_PDF);
....
Result res = new SAXResult(fop. getContentHandler());


Does the lower look better--over the long term, will
it make FOP more well known, more used?

FWIW, FAD merged Driver into Fop some time ago. From memory, the only issues were to do with the AWT renderer and its re-start capability (which I gather is not functioning anyway.)


While we're at it, what about moving Fop to org.apache.fop?

Peter
--
Peter B. West <http://www.powerup.com.au/~pbwest/resume.html>

Reply via email to