Brian Slesinsky has posted comments on this change.

Change subject: Adding a DOM clear method to RootPanel
......................................................................


Patch Set 6:

(1 comment)

I still don't think it's necessary but I'm okay with a helper method if it's very simple to use.

....................................................
File user/src/com/google/gwt/user/client/ui/RootPanel.java
Line 316:   public void clear(boolean clearDom) {
How about calling this clearDom() and removing the boolean? If they don't want to clear the dom then they can call clear().

Rationale: clear(true) is less readable and memorable because you have to look up the method definition to see what "true" means. Hardly anyone would call this with any value other than a constant "true".


--
To view, visit https://gwt-review.googlesource.com/2512
To unsubscribe, visit https://gwt-review.googlesource.com/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I712989276142460b91514713eaf8d8f74dbecd7b
Gerrit-PatchSet: 6
Gerrit-Project: gwt
Gerrit-Branch: master
Gerrit-Owner: Daniel Kurka <danku...@google.com>
Gerrit-Reviewer: Brian Slesinsky <skybr...@google.com>
Gerrit-Reviewer: Daniel Kurka <danku...@google.com>
Gerrit-Reviewer: Goktug Gokdogan <gok...@google.com>
Gerrit-Reviewer: Leeroy Jenkins <jenk...@gwtproject.org>
Gerrit-Reviewer: Matthew Dempsky <mdemp...@google.com>
Gerrit-Reviewer: Thomas Broyer <t.bro...@gmail.com>
Gerrit-HasComments: Yes

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors
--- You received this message because you are subscribed to the Google Groups "GWT Contributors" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to google-web-toolkit-contributors+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to