On Sat, 2008-01-19 at 22:50 +0100, Robert Millan wrote:
> On Tue, Jan 15, 2008 at 07:00:55PM +0100, Robert Millan wrote:
> > On Tue, Jan 15, 2008 at 12:42:39PM -0500, Pavel Roskin wrote:
> > >
> > > On Tue, 2008-01-15 at 18:17 +0100, Robert Millan wrote:
> > > > - grub_dprintf ("mem", "Using memory for heap: addr=%p, size=%u\n",
> > > > addr, (unsigned int) size);
> > > > + grub_dprintf ("mem", "Using memory for heap: start=%p, end=%p\n",
> > > > addr, addr + size);
> > >
> > > Maybe addr+size-1 would be better? Inclusive boundaries are more
> > > intuitive. Just run "cat /proc/iomem" to see what I mean.
> >
> > Sounds better to me.
> >
> > Does this change (with addr + size -1) sound fine to everyone else?
>
> Uhm actually, since we already substract one on ieee1275 to workaround
> firmware bugs, this might get confusing.
Oh, I didn't know that.
> How about just "addr + size" ?
Fine with me.
--
Regards,
Pavel Roskin
_______________________________________________
Grub-devel mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/grub-devel