On Tue, 18 Dec 2007 17:14:31 -0600
Federico Mena Quintero <[EMAIL PROTECTED]> wrote:

> Back to my original question:  should this function be called
> g_format_size_for_display()?  It's not for files only.

Can I put in a vote for:

typedef enum {
  G_FORMAT_SIZE_BINARY,
  G_FORMAT_SIZE_DECIMAL,
  G_FORMAT_SIZE_USER,    // The user's preference
} gformat_size_type;

gchar *g_format_size_for_display(goffset size, gformat_size_type type);

Then perhaps a simple

gchar *g_format_file_size_for_display(goffset size) 
{
  return g_format_size_for_display(size, G_FORMAT_SIZE_BINARY);
}

-- 
Paul "LeoNerd" Evans

[EMAIL PROTECTED]
ICQ# 4135350       |  Registered Linux# 179460
http://www.leonerd.org.uk/

Attachment: signature.asc
Description: PGP signature

_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@gnome.org
http://mail.gnome.org/mailman/listinfo/gtk-devel-list

Reply via email to