On 4/21/06, Mikhail Loenko <[EMAIL PROTECTED]> wrote:
<SNIP>
> > I'm not sure. Module name IMHO doesn't make too much sense since it is
> > already 'coded' into accessor location and class location. I would
> > prefer <class_name>.<message intention> like
> > RandomAccessFile.file_is_closed
> > or something similar which keeps the idea of what the message is about.
>
> That would create more duplication like
>
> File.file_is_closed
> RandomAccessFile.file_is_closed

Agree. That's why I said 'something similar' :-)
For this particular case I would keep just

File.file_is_closed

and used it everywhere.

Prefix, IMHO is required just to split functional areas within a
module. It can be class name, but can also be some generalized
'functionality' name like Dialogs.ok_button

The main idea I'm trying to express is that:
- when looking into properties file it should be clear how (where)
each key is used just from its name
- when looking into the code should be clear the idea of the message
behind the key.

Wishes,
--
Anton Avtamonov,
Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to