Hi,

I agree with your suggestion - we may throw away both variables. I
just have missed this. About spaces after "if" please see [1]. This
was my code style guide. BTW, this seems to be a nice question. Do we
have some "officially approved" style guide in Harmony?

[1] http://java.sun.com/docs/codeconv/html/CodeConventions.doc7.html#682


2006/7/11, Mikhail Loenko <[EMAIL PROTECTED]>:
Hi Alexei

Why do you think that your proposed style:
    public Object get(Object oldInstance) {
        ObjectNode node;
        Object result;

        if (oldInstance == null) {
            return null;
        }

        node = nodes.get(oldInstance);
        result = getValue(node);

        return result;
    }

is more transparent than original one:
    public Object get(Object oldInstance) {
        if(oldInstance == null) {
            return null;
        }

        ObjectNode node = (ObjectNode) nodes.get(oldInstance);
        Object result = getValue(node);
        return result;
    }


I'd rather change it something like this way:
    public Object get(Object oldInstance) {
        if(oldInstance == null) {
            return null;
        }

        return getValue( (ObjectNode) nodes.get(oldInstance) );
    }
At least I'd get rid of the 'result' variable


Thanks,
Mikhail

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]




--
Alexei Zakharov,
Intel Middleware Product Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to