> $p is Point {x: 3, y: $y};
> // If $p->x === 3, bind $p->y to $y and return true.

> $p is Point {y: 37, x:@($x)};
> // $p->x === $x && $p->y == 37

I'm just going to put in my $0.02 here and downvote this syntax. I
believe that it should be swapped. IMO, `{x: 3, y: $y}` looks too
similar to the named arguments syntax.

Reply via email to