Hi On 2026-07-07 18:45, Paul M. Jones wrote:
I have updated the RFC and PR to add the `strict_namespace=1` directive as a way of solving for the global-fallback shadow-function case.
I believe the `strict_namespace=1` directive is a sufficiently unrelated concern - with enormous bikeshedding potential on its own [1], but also sufficient usefulness on its own - such that I feel it should be its own RFC that is a prerequisite to this one. It should not be piggy-backed onto function autoloading.
In particular the autoloading gotcha will remain (no autoloading if a matching function exists), unless the user remembers to set the declare, which isn't much better than the original proposal.
Best regards Tim Düsterhus [1] e.g. do we want to bundle this with a deprecation
