> On Jul 13, 2026, at 15:08, Paul M. Jones <[email protected]> wrote:
>
> Hi Tim,
>
>
>> On Jul 13, 2026, at 13:04, Tim Düsterhus <[email protected]> wrote:
>>
>> I believe the `strict_namespace=1` directive is a sufficiently unrelated
>> concern - with enormous bikeshedding potential on its own [1], but also
>> sufficient usefulness on its own - such that I feel it should be its own RFC
>> that is a prerequisite to this one. It should not be piggy-backed onto
>> function autoloading.
>
> I'm good with that. I'll prepare a separate RFC and remove that from the
> function-autoloading one.
Done: https://wiki.php.net/rfc/strict-namespace
I will update the function autoloading RFC as needed to refer back to
strict-namespace instead of incorporating it.
-- pmj