Hi Tim,
> On Jul 13, 2026, at 13:04, Tim Düsterhus <[email protected]> wrote: > > I believe the `strict_namespace=1` directive is a sufficiently unrelated > concern - with enormous bikeshedding potential on its own [1], but also > sufficient usefulness on its own - such that I feel it should be its own RFC > that is a prerequisite to this one. It should not be piggy-backed onto > function autoloading. I'm good with that. I'll prepare a separate RFC and remove that from the function-autoloading one. > In particular the autoloading gotcha will remain (no autoloading if a > matching function exists), unless the user remembers to set the declare, > which isn't much better than the original proposal. In fairness, that particular gotcha looks to be very rare among the top 1000 packages -- the principle remains, but in practice it appears almost nonexistent. -- pmj
