[ 
https://issues.apache.org/jira/browse/HBASE-4224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13182038#comment-13182038
 ] 

jirapos...@reviews.apache.org commented on HBASE-4224:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/3308/#review4236
-----------------------------------------------------------



/src/main/java/org/apache/hadoop/hbase/ServerName.java
<https://reviews.apache.org/r/3308/#comment9579>

    Please enclose the assignment on line 292 in curly braces.



/src/main/java/org/apache/hadoop/hbase/ServerName.java
<https://reviews.apache.org/r/3308/#comment9580>

    Since IPv4 support is built in, I suggest naming this method isValidHost.



/src/main/java/org/apache/hadoop/hbase/ServerName.java
<https://reviews.apache.org/r/3308/#comment9581>

    Why the extra line here ?



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9587>

    I think threadPool is a better name for this field.



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9582>

    I think Async is unnecessary here - that's what threads provide.



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9584>

    Why not call tableExists() directly ?



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9583>

    Should include the actual name passed in exception message.



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9585>

    Should read 'Exception parsing server name'



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9586>

    Since serverToRegionsMap has been created, you can return 
serverToRegionsMap here.



/src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java
<https://reviews.apache.org/r/3308/#comment9588>

    regions could be empty, right ?



/src/main/java/org/apache/hadoop/hbase/ipc/HRegionInterface.java
<https://reviews.apache.org/r/3308/#comment9589>

    This and flushAllRegions() are similar.
    Can we introduce just one new method which checks whether the list is empty 
to decide what to do ?
    i.e. move the check @ line 1403 of HBaseAdmin to the implementation of the 
new method.



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java
<https://reviews.apache.org/r/3308/#comment9590>

    Curly braces, please.



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java
<https://reviews.apache.org/r/3308/#comment9591>

    Do we need to place a try/catch block around line 2795 ?
    Currently the first failure would stop subsequent flushes.


- Ted


On 2012-01-06 18:48:11, Akash  Ashok wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/3308/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2012-01-06 18:48:11)
bq.  
bq.  
bq.  Review request for hbase.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  Flush by RegionServer
bq.  
bq.  
bq.  This addresses bug HBase-4224.
bq.      https://issues.apache.org/jira/browse/HBase-4224
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    /src/main/java/org/apache/hadoop/hbase/ipc/HRegionInterface.java 1226330 
bq.    /src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java 
1226330 
bq.    /src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java 1226330 
bq.    /src/main/java/org/apache/hadoop/hbase/ServerName.java 1226330 
bq.  
bq.  Diff: https://reviews.apache.org/r/3308/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Akash
bq.  
bq.


                
> Need a flush by regionserver rather than by table option
> --------------------------------------------------------
>
>                 Key: HBASE-4224
>                 URL: https://issues.apache.org/jira/browse/HBASE-4224
>             Project: HBase
>          Issue Type: Bug
>          Components: shell
>            Reporter: stack
>            Assignee: Akash Ashok
>         Attachments: HBase-4224-v2.patch, HBase-4224.patch
>
>
> This evening needed to clean out logs on the cluster.  logs are by 
> regionserver.  to let go of logs, we need to have all edits emptied from 
> memory.  only flush is by table or region.  We need to be able to flush the 
> regionserver.  Need to add this.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to