[ 
https://issues.apache.org/jira/browse/HBASE-4348?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13238923#comment-13238923
 ] 

jirapos...@reviews.apache.org commented on HBASE-4348:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/4402/#review6204
-----------------------------------------------------------


Himanshu, please address the potential NPE issue.  I've added some suggestions 
to keep names consistent with HBase's conventions.

It would be really nice if you could do a test that would exercise some of the 
new code (test updates don't really seem do it).  See TestRpcMetrics, or 
TestMetricsMBeanBase as possible modes.  I won't block committing if this 
doesn't happen, but it would be nice. :)


src/main/jamon/org/apache/hadoop/hbase/tmpl/master/AssignmentManagerStatusTmpl.jamon
<https://reviews.apache.org/r/4402/#comment13873>

    let's rename this to be consistent with other Configuration fields.  Check 
out HConstants.java to see the names of quite a few configuration variables to 
get a general idea of the pattern.
    
    My suggestion is something like:
    'hbase.metrics.rit.threshold.time'



src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
<https://reviews.apache.org/r/4402/#comment13857>

    Either:
    
    * javadoc to say this must not be null and add 
    'Preconditions.assertNotNull(masterMetrics,"master metrics should never be 
null") on initialization
    
    * add guards where masterMetrics is deref'ed to see if null.
    
    Seems like with your tests, adding the guard 'if !=null' guard to 
masterMetrics derefs in the next comment is easier.



src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
<https://reviews.apache.org/r/4402/#comment13874>

    ditto.  Actually, since it is used in a few places, you should probably to 
add this to the HConstants file.



src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java
<https://reviews.apache.org/r/4402/#comment13858>

    master metrics could npe here.



src/main/java/org/apache/hadoop/hbase/master/HMaster.java
<https://reviews.apache.org/r/4402/#comment13875>

    nit: spitting? (kind gross) maybe "emitting" (you use that word below) or 
"publishing"?



src/main/java/org/apache/hadoop/hbase/master/HMaster.java
<https://reviews.apache.org/r/4402/#comment13363>

    nit: funny spacing



src/main/java/org/apache/hadoop/hbase/master/metrics/MasterMetrics.java
<https://reviews.apache.org/r/4402/#comment13876>

    maybe rename to put rit in front so that it is consistent and will sort 
nicely?
    
    maybe 'ritOldestAge'?


- jmhsieh


On 2012-03-20 21:44:10, Himanshu Vashishtha wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/4402/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2012-03-20 21:44:10)
bq.  
bq.  
bq.  Review request for hbase.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  This patch is for adding Region in transition metrics to the HMaster 
metrics system. It also adds these metrics in the master ui, in the Region in 
transition section. I have attached the proposed new format in the jira 4348.
bq.  
bq.  
bq.  This addresses bug HBase-4348.
bq.      https://issues.apache.org/jira/browse/HBase-4348
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    
src/main/jamon/org/apache/hadoop/hbase/tmpl/master/AssignmentManagerStatusTmpl.jamon
 0dc0691 
bq.    src/main/java/org/apache/hadoop/hbase/master/AssignmentManager.java 
ae468ca 
bq.    src/main/java/org/apache/hadoop/hbase/master/HMaster.java c4b4d30 
bq.    src/main/java/org/apache/hadoop/hbase/master/metrics/MasterMetrics.java 
83abc52 
bq.    src/test/java/org/apache/hadoop/hbase/master/TestAssignmentManager.java 
d68ce33 
bq.  
bq.  Diff: https://reviews.apache.org/r/4402/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  Ran on a 5 node cluster and kill region servers randomly to observe the 
changes in the RIT metrics as emitted out by the Master's mxbean;
bq.  
bq.  mvn test passes without any failure.
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Himanshu
bq.  
bq.


                
> Add metrics for regions in transition
> -------------------------------------
>
>                 Key: HBASE-4348
>                 URL: https://issues.apache.org/jira/browse/HBASE-4348
>             Project: HBase
>          Issue Type: Improvement
>          Components: metrics
>    Affects Versions: 0.92.0
>            Reporter: Todd Lipcon
>            Assignee: Himanshu Vashishtha
>            Priority: Minor
>              Labels: noob
>         Attachments: 4348-metrics-v3.patch, 4348-v1.patch, 4348-v2.patch, 
> RITs.png, RegionInTransitions2.png, metrics-v2.patch
>
>
> The following metrics would be useful for monitoring the master:
> - the number of regions in transition
> - the number of regions in transition that have been in transition for more 
> than a minute
> - how many seconds has the oldest region-in-transition been in transition

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to