[ 
https://issues.apache.org/jira/browse/LUCENE-2285?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12839258#action_12839258
 ] 

Shai Erera commented on LUCENE-2285:
------------------------------------

bq. I'd be curious to know what you did

Ok, now you've made me compare the two :). I'm happy to see we both did the 
same thing, only you call your buffer 'current' while I call it 'buf'. Besides 
that I've included a static final EMPTY_ARGS instead of all the places where 
'new Object[0]' is passed. Nothing too fancy.

Another thing is that I wrote an Arabic and Hebrew stemmer, and combined them 
w/ the Snowball ones by introducing a stemmer class which can be either 
Snowball or anything else. I'll check if we're allowed to contribute the Hebrew 
stemmer to Lucene ...

BTW FYI - our legal department forbid us to use the Hungarian stemmer because 
of licensing/legal issues. Besides the stemmers that were originally provided, 
the Snowball project accepted additional ones like the Hungarian stemmer. 
However, for that one we weren't able to get a confirmation from the 
contributor his University indeed gave him permission to contribute the code. 
Don't know if it matters to anyone here (I've notified Martin Porter as well), 
but FYI. Our legal department does not permit us to use it (which is not 
surprising - they are legal ...). I don't want to derail this issue into 
Snowball discussion, so if you want to talk about it, I suggest we move it to 
the list.

> Code cleanup from all sorts of (trivial) warnings
> -------------------------------------------------
>
>                 Key: LUCENE-2285
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2285
>             Project: Lucene - Java
>          Issue Type: Improvement
>            Reporter: Shai Erera
>            Assignee: Uwe Schindler
>            Priority: Minor
>             Fix For: 3.1
>
>         Attachments: LUCENE-2285.patch, LUCENE-2285.patch, LUCENE-2285.patch
>
>
> I would like to do some code cleanup and remove all sorts of trivial 
> warnings, like unnecessary casts, problems w/ javadocs, unused variables, 
> redundant null checks, unnecessary semicolon etc. These are all very trivial 
> and should not pose any problem.
> I'll create another issue for getting rid of deprecated code usage, like 
> LuceneTestCase and all sorts of deprecated constructors. That's also trivial 
> because it only affects Lucene code, but it's a different type of change.
> Another issue I'd like to create is about introducing more generics in the 
> code, where it's missing today - not changing existing API. There are many 
> places in the code like that.
> So, with you permission, I'll start with the trivial ones first, and then 
> move on to the others.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to