[ 
https://issues.apache.org/jira/browse/KAFKA-49?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13225321#comment-13225321
 ] 

Jun Rao commented on KAFKA-49:
------------------------------

Prashanth,

Thanks for the patch. Overall, it looks pretty good. Some comments:
1. KafkaApis: Even when the produce request requires no ack, we will still need 
to send error code back. So we should always send a ProduceResponse. When no 
ack is specified, we probably don't need to send offsets back.
2. ProduceRequest.getNumMessages: rename it to something like 
getNumTopicPartitions
3. AsyncProducerTeest.testDefaultHanlderRetryLogic: doesn't really test retry
4. SyncProducerTest.testProduceBlocksWhenRequired: Use createTopic instead of 
creating ZK path directly.
5. I agree that it's probably better to use Seq in our requests/response, 
instead of Array. Then we need a java version to convert Seq to java array and 
vice versa. Please open a separate jira to track this.

                
> Add acknowledgement to the produce request.
> -------------------------------------------
>
>                 Key: KAFKA-49
>                 URL: https://issues.apache.org/jira/browse/KAFKA-49
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.8
>            Reporter: Jun Rao
>            Assignee: Prashanth Menon
>             Fix For: 0.8
>
>         Attachments: KAFKA-49-v1.patch
>
>
> Currently, the produce request doesn't get acknowledged. We need to have a 
> broker send a response to the producer and have the producer wait for the 
> response before sending the next request.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to