Joe Perches wrote:
On Tue, 2007-02-13 at 11:20 +1100, Ben Nizette wrote:

 #define array_for_each(element, array) \
        for (int __idx = 0; __idx < ARRAY_SIZE((array)); \
                __idx++, (element) = &(array[__idx]))


This requires all interior loop code be changed.

Ben is right though. Making this thing confusing to use is going
to be worse than sticking with the very simple and unconfusing
loops.

If you really wanted to introduce your loop, then please call it
array_for_each_idx, or something to distinguish it.

--
SUSE Labs, Novell Inc.
Send instant messages to your online friends http://au.messenger.yahoo.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to