> > -   if (rdma_node_get_transport(ib_device->node_type) !=
> RDMA_TRANSPORT_IB)
> > -           return;
> > +   int count = 0;
> 
> I'm ok with this as an intermediate patch but going forward if we are
> going to
> have calls like
> 
> static inline int cap_ib_cm_dev(struct ib_device *device)

I would rather keep everything to checking per port, not per device.  
Specifically, because we have code that does this:

> >             port = kzalloc(sizeof *port, GFP_KERNEL);
> >             if (!port)
> >                     goto error1;
> > @@ -3809,7 +3810,16 @@ static void cm_add_one(struct ib_device
> *ib_device)
> >             ret = ib_modify_port(ib_device, i, 0, &port_modify);
> >             if (ret)
> >                     goto error3;

It will also help keep the checks consistent, so that we don't end up with CM 
checks being per device, but SA checks being per port.

- Sean
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to