This patch add some definition for enrcyption xattr.

Signed-off-by: Jaegeuk Kim <jaeg...@kernel.org>
---
 fs/f2fs/xattr.h | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/fs/f2fs/xattr.h b/fs/f2fs/xattr.h
index 969d792..71a7100 100644
--- a/fs/f2fs/xattr.h
+++ b/fs/f2fs/xattr.h
@@ -35,6 +35,10 @@
 #define F2FS_XATTR_INDEX_LUSTRE                        5
 #define F2FS_XATTR_INDEX_SECURITY              6
 #define F2FS_XATTR_INDEX_ADVISE                        7
+/* Should be same as EXT4_XATTR_INDEX_ENCRYPTION */
+#define F2FS_XATTR_INDEX_ENCRYPTION            9
+
+#define F2FS_XATTR_NAME_ENCRYPTION_CONTEXT     "c"
 
 struct f2fs_xattr_header {
        __le32  h_magic;        /* magic number for identification */
-- 
2.1.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to