On Tue, Sep 29, 2015 at 02:55:13PM +0200, Frederic Weisbecker wrote: > On Tue, Sep 29, 2015 at 11:28:27AM +0200, Peter Zijlstra wrote: > > #define init_task_preempt_count(p) do { \ > > - task_thread_info(p)->preempt_count = PREEMPT_DISABLED; \ > > + task_thread_info(p)->preempt_count = 2*PREEMPT_DISABLED; \ > > Since it's not quite obvious why we use this magic value without looking > at schedule_tail() details, maybe add a little comment? (Just "/* see > schedule_tail() */").
Right, I fixed that in 12/11 v2. I'll change that around a bit. > > + /* > > + * Still have preempt_count() == 2, from: > > + * > > + * schedule() > > + * preempt_disable(); // 1 > > + * __schedule() > > + * raw_spin_lock_irq(&rq->lock) // 2 > > + */ > > I found that a bit confusing first, because that's a preempt_count() > we actually emulate for a new task. Maybe something like: > > + /* > + * New task is init with preempt_count() == 2 because prev task left > + * us after: > + * > + * schedule() > + * preempt_disable(); // 1 > + * __schedule() > + * raw_spin_lock_irq(&rq->lock) // 2 > + */ I think I'll move the comment to finish_task_switch(), but yes. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/