* Aneesh Kumar K V <aneesh.ku...@linux.ibm.com> [2023-11-14 15:45:35]:

> On 11/14/23 3:16 PM, Srikar Dronamraju wrote:
> > * Aneesh Kumar K.V <aneesh.ku...@linux.ibm.com> [2023-11-14 12:42:19]:
> > 
> >> No functional change in this patch. A helper is added to find if
> >> vcpu is dispatched by hypervisor. Use that instead of opencoding.
> >> Also clarify some of the comments.
> >>
> > 
> > If we are introducing vcpu_is_dispatched, we should remove 
> > yield_count_of() and use vcpu_is_dispatched everwhere
> > 
> > No point in having yield_count_of() and vcpu_is_dispatched, since
> > yield_count_of() is only used to check if we are running in OS or not.
> > 
> 
> We do
> 
> yield_count = yield_count_of(owner);
> yield_to_preempted(owner, yield_count);

yield_to_preempted is defined just below yield_count_of() and we are anyway
passing the CPU, so we dont have to pass yield_count to yield_to_preempted


-- 
Thanks and Regards
Srikar Dronamraju

Reply via email to