What do you think about this variation?

    Border.solid(Paint color, double width) ->
        new Border(new BorderStroke(color, BorderStrokeStyle.SOLID,
null, new BorderWidths(width)))

    Border.dashed(Paint color, double width)  ->
        new Border(new BorderStroke(color, BorderStrokeStyle.DASHED,
null, new BorderWidths(width)))

    Border.dotted(Paint color, double width) ->
        new Border(new BorderStroke(color, BorderStrokeStyle.DOTTED,
null, new BorderWidths(width)))

    Background.fill(Paint color) ->
        new BackgroundFill(color, null, null)

This gives developers a good deal of customizability before needing to
fall back to using constructors.


Am Di., 8. Juni 2021 um 03:21 Uhr schrieb Nir Lisker <nlis...@gmail.com>:
>
> The new API:
>
> 1. `Border.of(Paint stroke)` or `Border.stroke(Paint stroke)` that does
> `new Border(new BorderStroke(Paint stroke , BorderStrokeStyle.SOLID, null,
> null));`
> 2. `Background.of((Paint fill)` or `Background.fill(Paint fill)` that does
> `new Background(new BackgroundFill(Paint fill, null, null));`
>
> I don't mind either name choice.
>

Reply via email to