This PR is an audit of several snapping-related methods in `Region`, along with some bug fixes.
I've added a helper method `snapAligned()`, which does the exact same thing as `snapSpace()`, but clearly states that the author knows that the value is already pixel-aligned. In addition, I've renamed several local variables around a "rawFoo" and "snappedFoo" naming scheme, so as to make it easier to see what's what. This PR should probably be integrated before the other layout container PRs, because those use the `Region` layout methods. --------- - [x] I confirm that I make this contribution in accordance with the [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai). ------------- Commit messages: - fixes - tests Changes: https://git.openjdk.org/jfx/pull/2278/files Webrev: https://webrevs.openjdk.org/?repo=jfx&pr=2278&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8391279 Stats: 761 lines in 3 files changed: 625 ins; 15 del; 121 mod Patch: https://git.openjdk.org/jfx/pull/2278.diff Fetch: git fetch https://git.openjdk.org/jfx.git pull/2278/head:pull/2278 PR: https://git.openjdk.org/jfx/pull/2278
