On Mon, 31 Aug 2026 11:50:52 GMT, Michael Strauß <[email protected]> wrote:

>> This PR is an audit of several snapping-related methods in `Region`, along 
>> with some bug fixes.
>> 
>> I've added a helper method `snapAligned()`, which does the exact same thing 
>> as `snapSpace()`, but clearly states that the author knows that the value is 
>> already pixel-aligned. In addition, I've renamed several local variables 
>> around a "rawFoo" and "snappedFoo" naming scheme, so as to make it easier to 
>> see what's what.
>> 
>> This PR should probably be integrated before the other layout container PRs, 
>> because those use the `Region` layout methods.
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Michael Strauß has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   more render scales

modules/javafx.graphics/src/test/java/test/javafx/scene/layout/RegionTest.java 
line 2339:

> 2337: 
> 2338:     @ParameterizedTest
> 2339:     @ValueSource(doubles = { 1, 1.25, 1.5, 2.5 })

should we use the same `renderScales` method source in all the parameterized 
tests?

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/2278#discussion_r3898179000

Reply via email to