> This PR is an audit of several snapping-related methods in `Region`, along 
> with some bug fixes.
> 
> I've added a helper method `snapAligned()`, which does the exact same thing 
> as `snapSpace()`, but clearly states that the author knows that the value is 
> already pixel-aligned. In addition, I've renamed several local variables 
> around a "rawFoo" and "snappedFoo" naming scheme, so as to make it easier to 
> see what's what.
> 
> This PR should probably be integrated before the other layout container PRs, 
> because those use the `Region` layout methods.
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

Michael Strauß has updated the pull request incrementally with one additional 
commit since the last revision:

  more render scales

-------------

Changes:
  - all: https://git.openjdk.org/jfx/pull/2278/files
  - new: https://git.openjdk.org/jfx/pull/2278/files/8da60ebb..8391e817

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jfx&pr=2278&range=01
 - incr: https://webrevs.openjdk.org/?repo=jfx&pr=2278&range=00-01

  Stats: 3 lines in 1 file changed: 2 ins; 0 del; 1 mod
  Patch: https://git.openjdk.org/jfx/pull/2278.diff
  Fetch: git fetch https://git.openjdk.org/jfx.git pull/2278/head:pull/2278

PR: https://git.openjdk.org/jfx/pull/2278

Reply via email to