On Wed, 9 Sep 2026 06:49:17 GMT, Ajit Ghaisas <[email protected]> wrote:

> This is a minor test cleanup fix.
> Note : All tests in `ControlTooltipTest` were disabled/ignored since 
> beginning.
> 
> Fix :
> The test cases used to make an incorrect assumption that adding a `Tooltip` 
> to a `Control` adds it to `Control`'s children list. The old test cases are 
> discarded and new unit tests are added to test setting a `Tooltip` on a 
> `Control`.
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

modules/javafx.controls/src/test/java/test/javafx/scene/control/ControlTooltipTest.java
 line 40:

> 38: public class ControlTooltipTest {
> 39:     private ControlStub c;
> 40:     private Tooltip t;

I wonder if we want to improve the readability of the variables while here.
So `c` -> `control`, `t` -> `tooltip` ?

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/2304#discussion_r3967840456

Reply via email to