On first, thanks for your quickly answer.

That's true, I took only this lines from my log file.

I paste here the log from another connection attempt:

Jan 30 18:04:31 correo1 dbmail/imap4d[14702]: Message:[serverchild] serverchild.c,PerformChildTask(+349): incoming connection from [10.0.0.1] by pid [14702]
Jan 30 18:04:44 correo1 postfix/smtpd[20693]: connect from unknown[10.0.0.1]
Jan 30 18:04:44 correo1 postfix/smtpd[20693]: setting up TLS connection from unknown[10.0.0.1] Jan 30 18:04:44 correo1 postfix/smtpd[20693]: Anonymous TLS connection established from unknown[10.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits) Jan 30 18:04:44 correo1 postfix/smtpd[20693]: warning: TLS library problem: 20693:error:14094412:SSL routines:SSL3_READ_BYTES:sslv3 alert bad certificate:s3_pkt.c:1108:SSL alert number 42: Jan 30 18:04:44 correo1 postfix/smtpd[20693]: lost connection after STARTTLS from unknown[10.0.0.1] Jan 30 18:04:44 correo1 postfix/smtpd[20693]: disconnect from unknown[10.0.0.1]

I connect to the server using Mozilla Thunderbird.

Thanks again.

On Thu, Jan 30, 2014 at 12:23:28PM +0100, Jaime Fuentes - Ditecal wrote:

I am implementing a Mail Server using postfix + dbmail. I recently
configured STARTTLS and I found that lines on my */var/log/mail.log*

    Jan 29 19:59:56 correo2 postfix/smtpd[3384]: warning: TLS library
    problem: 3384:error:14094412:SSL routines:SSL3_READ_BYTES:sslv3
    alert bad certificate:s3_pkt.c:1108:SSL alert number 42:
    Jan 29 20:03:42 correo2 postfix/smtpd[3495]: warning: TLS library
    problem: 3495:error:14094412:SSL routines:SSL3_READ_BYTES:sslv3
    alert bad certificate:s3_pkt.c:1108:SSL alert number 42:
There is nothing wrong with your server, it is just reporting the
fatal alert from the remote client.  SSL/TLS alerts are reports of
problems fromt the remote SSL/TLS peer.

You've left out essential context.  What are the other log entries
for "postfix/smtpd[3384]" and/or "postfix/smtpd[3495]" directly
before and after the warnings above.

I don't know what mean this lines, because when I probe the
connection with the command:
They mean that the remote SMTP client was for some reason unhappy
with your certificate.  Perhaps some MUA, expecting certificates
from a "trusted" CA, is failing to authenticate your self-signed
server certificate.

You need to find out what client was connecting to the Postfix SMTP
server to cause these messages.  Perhaps also check for further
connections from the same IP address and look at those...



______________________________________________________________________
OpenSSL Project                                 http://www.openssl.org
User Support Mailing List                    [email protected]
Automated List Manager                           [email protected]

Reply via email to