On Thu, Aug 03, 2000 at 10:53:02AM +0100, Hildo Biersma wrote:
> If functions could distinguish between
> 'wantarray' and 'wanthahs' this would be easy to do.
Due to the recent "rename local()" and "can't return an array"
discussions here, we should also consider "rename wantarray()"
as well.
It should be named wantlist(), because it does not tell you
if it wants an array, it tells you whether you were called in
list context or not.
I will RFCify this within the next few days (unless someone
can shoot it down right now).
Tangentially related:
If the list/array distinction is retained in Perl 6, the docs
need to be much more careful about not misusing the terms.
There are (at least) dozens of loosy-goosy uses of "array"
where "list" is more accurate.
(off-topic here, but I'm patiently waiting for a "docs list"
to be established before letting lose with several RFCs
regarding documentation, markup, indexing/searching,
audience level, etc...
Please don't reply to this tangent part, let's wait for a "docs list".
Nat,
Can we set one of those up now, or should we wait until
Ziggy can breathe?
)
--
Tad McClellan SGML consulting
[EMAIL PROTECTED] Perl programming
Fort Worth, Texas
- Re: wanthash (Was: Re: date interface (was Re... Tom Christiansen
- Re: wanthash (Was: Re: date interface (wa... Johan Vromans
- Re: wanthash (Was: Re: date interface (wa... Damian Conway
- Re: wanthash (Was: Re: date interface... Piers Cawley
- Re: wanthash Dan Sugalski
- Re: wanthash Peter Scott
- Re: wanthash Graham Barr
- Re: date interface (was Re: perl6 requirements, o... Simon Cozens
- Re: date interface (was Re: perl6 requirement... Tom Christiansen
- Re: date interface (was Re: perl6 require... Simon Cozens
- Re: wantarray() should be named wantlist() (was R... Tad McClellan
- Re: wantarray() should be named wantlist() (w... Jonathan Scott Duff
- Re: wantarray() should be named wantlist(... Clayton Scott
- Re: wantarray() should be named wantl... Jonathan Scott Duff
- Re: wantarray() should be named ... Nathan Wiger
- Re: wantarray() should be named ... skud
- Re: wantarray() should be named wantlist() (w... Graham Barr
- Re: wantarray() should be named wantlist() (was ... Damian Conway
- Re: wantarray() should be named wantlist() (w... Tad McClellan
- Re: date interface (was Re: perl6 requirements, on boo... Tom Christiansen
- Re: date interface (was Re: perl6 requirements, o... Matt Sergeant
