stepharong wrote:
>can we rename this selector?
>asMethodConst should be at least be renamed to asConstantMethod

When you use "as {something}" then "something" depicts the result of the 
conversion message sent to an object.

Like in #asNumber or #asString which shows to what the receiver will be 
converted.


My understanding is that in the case discussed the receiver object is 
NOT converted to a constant unchangeable method, so #asConstantMethod would 
not fit as a selector.

Instead it is sent to an object that afterwards is a constant within a method
(so it will not be evaluated later at runtime again) so IMHO #asMethodConstant 
instead of #asMethodConst would be better.

Finding good names is really hardest part in programming...

Thanks
T.

Reply via email to