On 3 September 2012 16:45, Javier Pimás <elpochodelage...@gmail.com> wrote:
> Here we use a convention of naming 0 based accessors with atOffset: and
> atOffset:put:. If applicable, this could be a good tradeoff. Of course, the
> arguments are simple integers, but the 0 index gets explicit by the
> selector.
>

mmm..  this is more explicit, i agree, but then all selector names
will get longer.

In our case we're talking about bunch of selectors where first keyword
denotes a type:

nbFloat32At:
nbFloat64At:
nbInt16At:
....
nbUInt32At:
... etc


for me it is not a problem, since 'nb' prefix kinda already says
something , like 'watch it, you entering different domain here'..
And , of course renaming 'index' to 'offset' for argument names will
also can serve for clarity..
(sure thing you won't see the method's argument name while coding
unless you browse the implementation).

So, maybe it is not necessarily?

So, lets vote for the final form and then i will put it all in uniform
way everywhere.


foo nbInt64At: 0
vs
foo nbInt64AtOffset: 0

what is your pick?

-- 
Best regards,
Igor Stasenko.

Reply via email to