On Fri, 14 Jul 2006, Yegor Kozlov wrote:
OK. The said makes sense.

I'm not sure about method signatures, need to think about it :).

I was suggesting the idea, not the name. They almost certainly need to have a totally different name!

Probably there will be
getStyles();  //returns all applied styles
and
getStyles(int mask);  //returns specific styles

Hmm, I'd probably go with
 getStyles()
 getStylesAll()  - same as above
 getStylesTextRun()
 getStylesMaster()
but that's just me. If we do do the mask thing, we should have a "ALL" mask too

We are going to add a bunch of methods to the TextRun object, probably
it's better to delegate calls to a special object :

I'd be happy with that - we could also shift some of the logic from RichTextRun (for dealing with the actual StyleTextPropAtoms) there too

Nick

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
Mailing List:    http://jakarta.apache.org/site/mail2.html#poi
The Apache Jakarta POI Project: http://jakarta.apache.org/poi/

Reply via email to