On Sat, Jul 30, 2011 at 1:17 AM, Antoine Pitrou <solip...@pitrou.net> wrote:
> On Thu, 28 Jul 2011 11:28:43 +0200
> Victor Stinner <victor.stin...@haypocalc.com> wrote:
>>
>> I will add your alternative to the PEP (except if you would like to do
>> that yourself?). If I understood correctly, you propose to:
>>
>>   * rename codecs.open() to codecs.open_stream()
>>   * change codecs.open() to reuse open() (and so io.TextIOWrapper)
>>
>> (and don't deprecate anything)
>
> This may be an interesting approach. In a few years, we can evaluate
> whether users are calling open_stream(), and if there aren't any, we
> can deprecate the whole thing.

Indeed. I'm also heavily influenced by MAL's opinion on this
particular topic, so the fact he's OK with this approach counts for a
lot. It achieves the main benefit I'm interested in (transparently
migrating users of the codecs.open API to the new IO stack), while
paving the way for eliminating the redundancy at some point in the
future.

Cheers,
Nick.

-- 
Nick Coghlan   |   ncogh...@gmail.com   |   Brisbane, Australia
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to