On 12/5/19 12:17 PM, Eric Blake wrote:
On 12/5/19 11:46 AM, Vladimir Sementsov-Ogievskiy wrote:
Make qbus_list_bus and qbus_list_dev hint append helpers well formed:
switch errp paramter to Error *const * type, as it has uncommon
behavior: not change the pointer to return error, but operate on
already existent error object.
Rename functions to be error_append_*_hint.

qbus_error_append_*_hint


Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com>
---
  qdev-monitor.c | 12 +++++++-----
  1 file changed, 7 insertions(+), 5 deletions(-)


-static void qbus_list_dev(BusState *bus, Error **errp)
+static void qbus_error_append_dev_list_hint(BusState *bus,
+                                            Error *const *errp)

Or, since you copy-and-paste this commit message in v9, you could use

Sorry, I meant it was copied in v8 7/21.

*_error_append_*_hint between the commits for less one-off fixing per message.


--
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3226
Virtualization:  qemu.org | libvirt.org


Reply via email to